Entries from January 2011

SCCM: Client steigt immer wieder aus PE aus

Ich hatte aktuell das Problem, dass eine neue Lieferung von HP Elite PC 8100 SFF Rechnern einfach aus dem PE-Modus ausstiegen, ohne die Tasksequenz zu starten.
Mein Testrechner, dasselbe Modell, jedoch schon Ende letzten Jahres geliefert, macht keine Probleme.
Nach der Analyse des Logfiles durch Drücken von F8 während des PEs sah ich, dass die Maschine offenbar Probleme hat eine Netzwerkverbindung herzustellen. Ausschlaggebend dafür waren die Einträge:

QUOTE:

Failed to download pxe variable file. Code(0x00000001) TSPxe
PxeGetPxeData failed with 0x80004005 TSPxe


Ein "ipconfig" ergab: nichts.
Da mein anderer Testrechner am selben Anschluss problemlos funktioniert, muss es also an den Netzwerktreibern - oder besser - an einem fehlenden Netzwerktreiber liegen.
Ich konnte zuvor keine Windows 7-Treiber einbinden, was ich jedoch durch das Einspielen eines Hotfixes ausbügeln konnte (KB978754).
Also importierte ich Windows Vista-Treiber, erhielt hier jedoch immer wieder die Meldung, dass die jeweiligen Treiber bereits importiert wurden. Das Einspielen des Hotfixes KB2213600 schaffte auch hier Abhilfe. Desweiteren musste ich Berechtigungen (Share und NTFS) auf meinem Ordner für das Anlegen der Treiberpakete ändern und erst das Zulassen von "Full Control" für "Everybody" war notwendig, damit ich Treiber zu Treiberpaketen hinzufügen konnte, ohne dass ich eine Fehlermeldung erhielt und das SmsAdminUI.log weiter vollief. Keine schöne Lösung, war aber erstmal notwendig, um alle Fehler zu beseitigen. In den nächsten Tagen werde ich die Rechte wieder soweit einschränken, dass noch alles funktioniert, aber "Everybody" keinen full access mehr hat.

Weil auch das Importieren dutzender weiterer Netzwerktreiber (Intel) und deren Hinzufügen zum Boot Image nichts brachte, installierte ich Windows 7 eben kurzerhand manuell.
Anschließend probierte ich über die Treiberaktualisierung via Gerätemanager alle mir vorliegenden Treiber durch. Nichts !
Dann sah ich mir mithilfe SIWs das Modell der Netzwerkkarte an und lud von der Intel-Seite (davor HP) ein Treiberpaket runter, das die verbaute Karte mit abdeckte.
Nach dem Entpacken der EXE wählte ich einen Treiber aus einem Unterverzeichnis und notierte mir dessen Bezeichnung nach erfolgreicher Installation.
Und eben diesen Treiber lud ich abschließend einzeln in den SCCM und packte ihn ins Boot Image, was zur Folge hatte, dass meine Rechner jetzt auch die Tasksequenz anstoßen und durchlaufen.

*ächz*

Ist mal wieder typisch SCCM. Mal schnell etwas gemacht - kannste vergessen. Mal eben einen Fehler beheben ? Haste gedacht ! Einen Fehler beheben, bringt weitere Fehler, die es zu beheben gilt, die jedoch weitere Fehler bringen, die........ .

Naja, jetzt läuft's jedenfalls. :-)

Ansonsten gibt's zu diesem Thema auch einen hilfreichen Beitrag unter http://blogs.technet.com.

Windows Server 2008: Als anderer Benutzer ausführen

Es kommt gerne mal vor, dass man eine Applikation als anderer Benutzer ausführen will, zum Beispiel, wenn diese für die Installation bestimmte Berechtigungen benötigt. Da man sich jedoch ungern als Domain-Admin oder eben der andere User an einem System anmelden will, gibt es den Punkt "Als anderer Benutzer ausführen...", der sich im Kontextmenü findet, wenn man eine Datei mit "SHIFT" und Rechtsklick auswählt.
Unter Windows Server 2008 sucht man diesen Punkt jedoch vergebens.
Abhilfe schafft hier ein kleines, von Mark Russinovich (Sysinternals) geschriebenes Tool, das den Kontextmenüeintrag erstellt.

ShellRunAs (über diesen Link erreichbar) ist schnell von der Microsoftseite heruntergeladen. Anschließend kopiert man das kleine Tool auf dem Server nach ..\Windows\system32 und ruft die Eingabeaufforderung auf, in der man "shellrunas /reg" (ohne die "") eingibt.
Und das war's auch schon. Danach steht einem der Eintrag "Als anderer Benutzer ausführen..." im Kontextmenü zur Verfügung. Ein Neustart des Systems ist nicht erforderlich !

SCCM: PXE-E32: TFTP open timeout

Wer beim Booten eines Clients plötzlich einen TFTP Timeout mit dem Fehler "PXE-E32: TFTP open timeout" erhält, der sollte am SCCM den PXE Service Point, WDS oder aber BootImage und Distribution Point kontrollieren.
Im ersten Schritt ist es jedoch wichtig zu überlegen, was man zuletzt getan hat. Nahm man keinerlei Änderungen an der Konfiguration des SCCM vor, sondern erstellte lediglich ein neues Boot-Image, das man auf die Distribution Points verteilte, könnte auch das schon das Problem sein.
So war es zumindest bei mir der Fall.

Ich duplizierte ein bestehendes Boot Image, fügte Treiber hinzu, verteilte es auf die DPs (normal und PXE) und erstellte anschließend eine Task-Sequenz, die das neue Boot Image beinhaltete und kündigte diese an. Hiernach brachte mein Testrechner obige Fehlermeldungen.
Als Resultat liefen Fehlermeldungen im PXEControl.log auf, die anzeigten, dass eine Antwort von PXE fehl schlug:

QUOTE:

PXE test request failed, status code is -2147467259, 'Error receiving replies from PXE server'. SMS_PXE_SERVICE_POINT 1/18/2011 12:57:52 PM 3668 (0x0E54)
Successfully performed availability check against local computer. SMS_PXE_SERVICE_POINT 1/18/2011 12:57:52 PM 3668 (0x0E54)
adding address to server list 172.16.00.124 SMS_PXE_SERVICE_POINT 1/18/2011 12:57:52 PM 3668 (0x0E54)
adding address to server list 127.00.00.01 SMS_PXE_SERVICE_POINT 1/18/2011 12:57:52 PM 3668 (0x0E54)
Sending availiability packet to: 172.16.0.124 SMS_PXE_SERVICE_POINT 1/18/2011 12:57:52 PM 3668 (0x0E54)
Sent 274 bytes to 172.016.000.124:4011 SMS_PXE_SERVICE_POINT 1/18/2011 12:57:52 PM 3668 (0x0E54)
Error receiving replies SMS_PXE_SERVICE_POINT 1/18/2011 12:58:07 PM 3668 (0x0E54)


Desweiteren ließ sich der WDS-Dienst nicht starten und im Eventlog tauchten folgender Fehler auf:

QUOTE:

On 1/18/2011 11:57:30 AM, component SMS_PXE_SERVICE_POINT on computer MY-TEST-01 reported: PXE Control Manager detected PXE service point is not responding to PXE requests. The error is 16389.

Possible cause: PXE service point is not started or not responding.
Solution: Manually restart the PXE service point.

Possible cause: WDS service is not responding.
Solution: Manually restart the WDS service.



QUOTE:

Faulting application svchost.exe_WDSServer, version 6.0.6001.18000, time stamp 0x47918b89, faulting module wimgapi.dll, version 6.1.7600.16385, time stamp 0x4a5bc0a7, exception code 0xc0000005, fault offset 0x00028fe5, process id 0x334, application start time 0x01cbb70073ec8cdc.



Um Fehler, die in Zusammenhang mit PXE und WDS stehen, zu finden und zu beheben, gibt es diese hervorragende Seite: http://blogs.technet.com/b/smsandmom/archive/2008/09/17/configmgr-2007-troubleshooting-pxe-service-point-issues-and-wds-service-not-starting.aspx.

Bevor ich jetzt jedoch anfing, meinen PXE Service Point zu löschen, den Server neu zu starten, WDS zu deinstallieren usw., überlegte ich znächst welche Änderungen ich als letztes gemacht hatte. Und das waren eben jene oben genannte.
Also löschte ich kurzerhand die Ankündigung und das Boot Image und nach wenigen Sekunden waren die Einträge im PXEControl-log auch wieder positiv:

QUOTE:

adding address to server list 172.16.00.124 SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
adding address to server list 127.00.00.01 SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
Sending availiability packet to: 172.16.0.124 SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
Sent 274 bytes to 172.016.000.124:4011 SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
PXE test request succeeded. SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
Successfully performed availability check against local computer. SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
Initialization successfully completed within the allowed interval. SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
Received a registry change notification. SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
------ RegisterForNotification(): Registering again! ------- SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
Successfully handled registry changes. SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
Received a registry change notification. SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
------ RegisterForNotification(): Registering again! ------- SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
Successfully handled registry changes. SMS_PXE_SERVICE_POINT 1/18/2011 12:58:23 PM 3668 (0x0E54)
adding address to server list 172.16.00.124 SMS_PXE_SERVICE_POINT 1/18/2011 1:03:23 PM 3668 (0x0E54)
adding address to server list 127.00.00.01 SMS_PXE_SERVICE_POINT 1/18/2011 1:03:23 PM 3668 (0x0E54)
Sending availiability packet to: 172.16.0.124 SMS_PXE_SERVICE_POINT 1/18/2011 1:03:23 PM 3668 (0x0E54)
Sent 274 bytes to 172.016.000.124:4011 SMS_PXE_SERVICE_POINT 1/18/2011 1:03:23 PM 3668 (0x0E54)
PXE test request succeeded. SMS_PXE_SERVICE_POINT 1/18/2011 1:03:23 PM 3668 (0x0E54)


Und auch der WDS Dienst war automatisch gestartet, was man nach einem Refresh der Ansicht im Windows Deployment Services GUI sehen konnte.
In Folge dessen bootete auch mein Test-PC wieder ohne TFTP Timeout.

Für meinen Versuch werde ich das Boot Image also nicht mehr duplizieren, sondern ein neues über den Assistenten anlegen - und dann weitersehen.


Firewall oder Firewall ?

Firewall oder Firewall - wo ist hier der Unterschied werdet Ihr Euch fragen; und genau das tu ich auch. Zumindest, wenn es um die Schreibweise bzw. die Aussprache geht.
Also ich übersetze Firewall mit "Brandmauer", also einer "heißen" Schutzeinrichtung gegen Eindringlinge. Wird schon nicht im umsonst iim Englischen "Fire" und "Wall" heißen.
Wieso aber schreiben manche statt "die" Firewall von "der" Firewall ? Von einem Wall ? So wie dem Limes ? Dem Römischen Grenzwall ? Mag sein, denn auch der sollte Eindringlinge abhalten, aber macht es dann nicht Sinnn, das Wort gleich ganz einzudeutschen und "Feuerwall" oder so zu schreiben ?
Selbst Windows XP bringt in seiner gelben Blase den Hinweis: "Kein Firewall aktiviert". Schlecht eingedeutscht oder nur halb übersetzt ? Ja, wie heißt's denn nun ? Und wieso schreibt und spricht das Gros von "der Firewall" ?

Ebenso verhält es sich mit Routern, in denen man gerne mal Routen definiert und durch die Datenpakete geroutet werden. "Routen" ist also das Stichwort. Und wie spricht man's aus ? Wohl doch wie die berühmte "Route 66". Oder ? Und dennoch gibt es einige, die nennen das Ding "Router", ausgesprochen: "Rauter". Aha. Also Rauten kann ich hier keine entdecken, es sei denn das Ding wurde in Bayern produziert und mit einem entsprechenden Muster versehen. Oder werden die Datenpakete in rautenförmigen Strömen versendet ? Ich hab' keine Ahnung.

Klärt mich doch bitte einfach mal auf.

Sture Ignoranz

Da wir supporttechnisch in den nächsten zwei Wochen sehr dünn besetzt sind, schrieb ich mal wieder eine entsprechende E-Mail an alle Mitarbeiter und informierte sie über die geänderten Supportzeiten (09-17:30 statt 08-18:00 Uhr), wies auf mögliche Bearbeitungsverzögerungen hin und bat darum, dass uns primär E-Mails geschickt werden, weil die telefonische Erreichbarkeit nicht gewährleistet sein kann.
Wieso ? Naja, eine Person auf rund 100 interne, 80 externe und 30 Mitarbeiter in einem angebundenen Büro ist nicht gerade viel ! Und da nutzen auch Rufumleitungen auf's Handy nichts, weil man sich schlecht zehnteilen kann.

Aber was hätte ich erwarten sollen ? Geschätzte 40% lesen unsere E-Mails eh nicht, was deutlich wird, da es offenbar allen scheißegal ist, was ich schreibe, denn das Telefon klingelt trotzdem ständig. Zudem fiel einem Mitarbeiter gerade jetzt ein, dass es Updates für seine Sonderanwendungen gibt, die natürlich heute noch installiert werden sollen. Eine Kollegin ruft, an, weil sie fünf Dateien abgelegt hat, die ich brennen soll. Hätte man auch per E-Mail schreiben können, aber ok. Nach drei Minuten steht ihr Azubi hier und soll die Scheiben abholen. Hallo ? Sie erhielt keine Nachricht, kein Ticket - aber meine E-Mail von wegen verzögeter.....aber ist ja auch egal.

Und so rufen fröhlich Außendienstmitarbeiter an, weil eine E-Mail an einen Empfänger nicht durchgegangen zu sein scheint (aufregend) oder ihre Kaffeemaschine heute vielleicht mal linksrum statt rechtsrum die Bohnen mahlt, andere quatschen mich voll: "Mann, Euch erreicht man ja mal wieder gar nicht !" (klar: mal wieder ! Aber was schrieb ich vorhin ?) und wieder andere möchten ihre drei neu bestellten PCs am besten noch bis morgen früh installiert, konfiguriert und aufgebaut bekommen haben.

Aber alles kein Problem, denn der Mann mit den acht Armen ist auf den Plan getreten ! Der Superheld des Supports ist da, um Euch armen Seelen zu helfen ! Also auf in den Kampf und her mit Euren Forderungen, denn der Tag hat ja nur 24 Stunden !

Page 1 of 3, totaling 14 entries