Entries from Nerdy Talk

Living Colors Leuchte brachte HUE Bridge durcheinander

Vorgestern wollte ich eine (weitere) Philips Living Colors Leuchte ("Bloom") mit meiner HUE-Bridge koppeln, damit ich die Lampe auch per Handy steuern kann (u.a. als dimmbares Wecklicht). Die Fernbedienung (2. Gen.) bietet ja leider nur zwei Favoritentasten. Ich hatte davor bereits eine Fernbedienung der 2. Generation gekoppelt sowie eine andere Living Colors Lampe. Somit wusste ich was zu tun ist. Und bevor die Frage aufkommt, weshalb ich eine Living Colors kopple und nicht gleich die "Bloom Friends of Hue" bestellte: weil die einfach 20,- € mehr kostet !

Und so führte ich zunächst das übliche Prozedere durch:

1. HUE-Bridge auf Werkszustand zurücksetzen
2. LC Fernbedienung auf Werkszustand zurücksetzen
3. Tastenkombination "0" und das Symbol mit der kleinen "Sonne" für fünf Sekunden gleichzeitig gedrückt halten
4. Anschließend die FB direkt an die Bridge halten, auf ihr den blauen Connectbutton drücken und auf der FB die Tasten "I" und "Favorit 1" gleichzeitig gedrückt halten, bis der blaue Ring erlischt
5. An meine eingeschaltete LC Lampe gehen, FB dran halten und die Taste "I" gedrückt halten, bis die Lampe die Farben wechselt
6. Die FB nun wieder an die Bridge halten, den Connectbutton drücken und und auf der FB die Taste "I" solange drücken, bis der Ring um den Connect Button wieder blau leuchtet.

Soweit so gut. Da ich die Bridge ja auf den Werkszustand zurückgesetzt hatte, musste ich sie wieder meine HUP Lampen suchen lassen, aber die konnten allesamt nicht mehr gefunden werden und auch der Hue Tap Schalter wurde nicht mehr erkannt. Da mehrere Versuche der automatischen Erkennung fehlschlugen, fügte ich die Birnen manuell per Eingabe der Seriennummer hinzu. Immerhin wurde die "Bloom" von selbst erkannt. Das manuelle Hinzufügen klappte soweit auch, bis auf eine Birne, die partout nicht hinzugefügt werden konnte.

In so einem Fall hat man dann die Möglichkeit, die Birne einzuschicken, die Anwendung "Lampstealer" zu verwenden, die Birne per Telnet der Bridge zu melden oder oder oder. Der Grund, dass eine Birne mal nicht erkannt wird, liegt meist daran, dass sie noch einer (anderen) Bridge zugewiesen ist oder aber, dass die Bridge selbst noch Daten gespeichert hat und das Überschreiben selbiger nicht sauber verarbeitet.

Da ich weder Lust hatte, die Birne einzusenden, noch den Rechner hochzufahren, um Lampstealer herunterzuladen und zu starten, verband ich mich per Smartphone via Telnet mit der Bridge (Telnet auf die Bridge-IP auf Port 30000) und setzte folgenden Befehl ab:

[Link,Touchlink]

Doch dabei passiert genau: nichts.
Ich wiederholte dies, was aber denselben Effekt hatte. Hätte alles geklappt, hätte die Lampe geblinkt und die Bridge eine Meldung ausgegeben. Selbst eine Fehlermeldung wäre schon mehr gewesen als das was hier passierte.
Ich hatte also die Bridge und gespeicherte Daten in Verdacht und trennte sie daher für 30 Sekunden vom Strom. Danach verband ich mich erneut per Telnet und siehe da, Nummer 5 lebt:



Die Lampe blinkte, ich startete die Philips Hue App und ließ sie nach neuen Lampen suchen und da war sie auch wieder. Ich benannte sie final noch um, damit sie wieder so hieß wie zuvor, damit meine Apps wie "Hue Pro" wieder funktionieren.
Damit ist die Living Colors also eingebunden und lässt sich über Hue Apps via Smartphone und Tablet steuern. Die Fernbedienung könnte man sogar noch nutzen, um sie an anderen Birnen anzulernen, um diese damit zu steuern.

War aber einfach wieder nur nervig, dass natürlich mal wieder nichts rund lief. Aber wieso auch ? ;-)

FireTV Stick: Installation von Kodi und mehr

Dass der Amazon FireTV Stick bei mir nicht im Einsatz sein kann, ohne dass ich dran rumbasteln muss, war mir von Anfang an klar.
Und somit musste heute also zunächst Kodi und danach dieses und jenes draufgepackt werden.

Als erstes aktivierte ich dazu in den Einstellungen das Debugging und ließ die Installation von Fremd-Apps zu.
Die Installation der Apps, die übrigens ohne rooten möglich ist, könnte man mit der "Amazon Fire TV Utility App" bei der Kaspersky beim Extrahieren jedoch ein Schadprogramm in Form einer *.apk meldete und diese auch gleich löschte. Eine Alternative wäre "adbFire", dessen Verwendung auf im Kodi Wiki beschrieben wird, bei dem Kaspersky jedoch auch anschlägt und eine Datei löscht. Daneben gibt es noch das eine oder andere weitere Tool für Windows & Co., doch ich entschied mich für "AGK Fire", eine App für Android und iOS, die die Installation von Apps ganz bequem über's Smartphone ermöglicht.

In "AGK Fire" trug ich die IP meines FireTV Sticks ein, dem ich zuvor eine feste IP zugewiesen hatte, damit alle Apps, die mit dem Stick zusammenarbeiten sollen, auch zukünftig funktionieren.
Die App fand den Stick auch schnell und der Rest war ebenfalls schnell geschehen. Das Prinzip ist einfach: AGK Fire listet alle auf dem Smartphone installierten Apps auf. Tippt man die gewünschte an, kann man sie über einen Dialog auf dem FireTV installieren. Vermutlich wird die App dabei im Hintergrund wieder zu einem *.APK geschnürt, diese übertragen und auf dem FireTV wieder extrahiert und installiert. So oder so: es funktioniert problemlos. Mit "Kodi" fing ich an und der Vorgang dauerte eine Weile, was mich misstrauisch machte, doch Übertragung und Installation waren erfolgreich. Beim "ES Datei Explorer" scheiterte "AGK Fire" jedoch und brachte eine Fehlermeldung. Und als ich den Amazon App Store übertragen hatte, konnte ich diesen auf dem FireTV Stick nicht mehr sauber starten. Es erscheint nur der "Weiter"-Button, der jedoch nicht reagiert, ganz gleich was man drückt. Hier muss ich noch ein wenig rumprobieren und mal sehen, woher ich die ursprünglich installierte App wieder bekomme.
*UPDATE* Nach zahlreichen Drücken auf das Steuerrad konnte ich plötzlich zu den einzelnen Links auf der Shop Startseite springen und damit auch auf den "Weiter"-Button und diesen drücken. Nun funktioniert der Appstore wieder, der allerdings auf der von mir installierten APK basiert und - so wie ich gelesen habe - mehr bietet als der vorinstallierte.

Was Kodi jedoch angeht, so läuft es (in der Version 14.2) absolut reibungslos und flüssig. Das Abspielen von Full HD Titeln mit Größen von 10 GB aufwärts läuft, von einer Festplatte im Netzwerk abgespielt, über's WLAN und den Stick einwandfrei und ruckelfrei. Auch Diashows von einer Netzwerkplatte lassen sich problemlos abspielen und die Steuerung via "Yatse" klappt ebenfalls. So auch das Streaming von Videos vom Smartphone via Yatse zu Kodi auf dem FireTV Stick. Aber man kann's auch übertreiben. :-D

"adbFire" testete ich im Übrigen danach auch noch und die Anwendung funktioniert ebenfalls soweit problemlos. Damit gelang auch die Installation des ES Datei Explorer sowie von FING.
Eine Liste mit getesteten App findet man hier: http://forum.xda-developers.com/showthread.php?t=2756608

OSMC drahtlos - Keine WLAN-Verbindung

So, nach der Einrichtung und dem kabelgebundenen Test folgte ein Test über WLAN. Zum Einsatz kommt ein Edimax WLAN-Adapter in einem der vier USB-Ports. Der Adapter blinkt auch, aber OSMC bekommt offenbar keine Netzwerkverbindung. Am MAC-Filter des Routers liegt's nicht, denn ich schaltete diesen hierfür extra aus. Ein Scan mit "FING" über mein Smartphone zeigte den RPi auch nicht an. Was war also los ?

Um die WLAN-Verbindung zu prüfen und im Zweifelsfall zu initiieren, macht man unter OSMC folgendes.

1. Man verlässt OSMC und drückt beim Reboot die "Esc"-Taste
2. An der Konsole meldet man sich mit "osmc" und "osmc" an
3. Als nächstes gibt man folgende Befehle, jeweils per Enter-Taste bestätigt, ein:

connmanctl
technologies
scan wireless (jetzt sollte man zumindest schonmal sehen wie der WiFi-Status ist)
enable wifi (falls WiFi abgeschaltet ist)
scan wifi
agent on
services (Um die WLANs in der Umgebung abzurufen)

Im nächsten Schritt verbindet man sich mit dem gewünschten WLAN:

connect wifi_c83a35ca4314_535454657374_managed_psk (wifi_c83a35ca4314_535454657374_managed_psk ist hier nur ein Beispiel)
Tip: Es muss nicht der ganze Eintrag abgetippt werden. Man nimmt lediglich den vorderen Part, der bei allen WiFis gleich ist (z.B. wifi_c83a35ca4314_) und drückt die "Tab"-Taste, um den Rest automatisch zu vervollständigen.

Nun sollte die Verbindung stehen und auch zukünftig automatisch hergestellt werden.

Ebendies war bei mir der Fall und ich konnte OSMC somit auch drahtlos nutzen.
Im ersten Versuch spielte ich dasselbe 1080p Videofile von der Festplatte im Netzwerk ab: ruckelfrei und problemlos.
Im zweiten Versuch streamte ich dasselbe File über den "ES Datei Explorer" auf meinem Smartphone via "Yatse" (ebenfalls als App auf meinem Telefon) zu OSMC. Ruckelfrei und problemlos !
Abschließend erstellte ich mit meinem Telefon einen Hotspot, verband den RPi über obige Schritte damit und streamte ein lokales Videofile von meinem Telefon über "Yatse" zu OSMC (IP des RPis lässt sich in den Netzwerkeigenschaften in OSMC einsehen). Und auch hier: ruckelfrei und problemlos.
Und auch die Steuerung von OSMC über "Yatse" sowie eine angeschlossene Logitech Funktastatur funktioniert reibungslos.

Somit Daumen hoch für die Rpi-OSMC-Kombination, die auch in der Alpha 4 schon wunderbar funktioniert und genau das macht was ich wollte.

In Kürze werde ich mal sehen wie ich das Amazon Prime Addon unter OSMC installieren kann. Sollte ich mit Bitvis, WinScp oder Putty draufkommen, müsste ich nur das Amazon Instant Videp ZIP-File rüberkopieren und über "System/AddOns/Aus ZIP installieren" installieren.


RPi 2 mit OSMC

Der RPi 2 lag nun Ende letzter Woche komplett mit allen Utensilien bei mir und es konnte los installiert werden.
Ich hätte ihn gerne mit Raspbmc bespielt, doch das wird nicht weitergeführt (die Update-Server werden ab Juni nicht mehr erreichbar sein), sondern durch OSMC ersetzt. Zudem lässt sich Raspbmc auf dem RPi 2 auch gar nicht installieren, zumindest wenn man NOOBS dafür verwendet. Bei dem Versuch einer Installation erhält man dann die Meldung: "Warning: incompatible Operating System(s) detected. The following OSes aren't supported on this revision of Raspberry Pi and may fail to boot or function correctly: RaspBMC".

Also entschied ich mich ohne Umschweife für die Alpha 4 von OSMC, lud mir den Windows-Installer herunter und legte los. Als Datenträger kommt bei mir eine 8 GB Micro SDHC von SanDisk zum Einsatz, die ich mit dem SD Formatter formatierte (Wichtig: "Format Size Adjustment = ON") und dann unter Windows mithilfe des Installers bespielte. Dieser führt in wenigen Schritten einfach und problemlos durch die Installation und keine fünf Minuten später steckte die Karte im RPi, der per Kabel mit dem Internet verbunden war. Der Bootvorgang lässt einen kurz mit dem Rainbow Screen warten, danach folgen drei Meldungen bezüglich dreier fehlender CPU Nodes, doch dann startet OSMC mit der Meldung: "Installing files", was ebenfalls wieder einen Moment dauert, wonach ein Reboot erfolgt und der RPi direkt in OSMC bootet.

OSMC basiert auf Kodi 4.1 und lässt somit auch die Installation der Kodi-Addons, Skins usw. zu. Es startet mit einer eigenen Skin, die sich in den Einstellungen jedoch auf "Confluence" umstellen lässt, die mir persönlich am besten gefällt. Wer XBMC oder Kodi kennt ist schnell mit der Konfiguration durch (Ländereinstellungen, ggfs. Addons nachinstallieren, Wiedergabeoptionen einstellen, usw.) und kann direkt loslegen.
Im ersten Versuch spielte ich einen 1080p Film von einer im Netzwerk hängenden Platte ab, was problemlos und völlig ruckelfrei funktionierte. Auch Addon-Installationen klappten sowie die Wiedergabe von Videos und Musik über diese. Somit macht OSMC in der Alpha 4 bereits einen super Eindruck. Als nächstes will ich noch sehen wie alles drahtlos funktioniert, denn die Itention ist der Einsatz des RPi 2 am kleinen Fernseher im Schlafzimmer. Dort habe ich keinen LAN-Anschluss und will auch keine weiteren Kabel haben. Aber dazu später mehr.


Xoro Pad 9719QR Root

Ich "erbte" von meinem Vater ein Xoro Pad 9719QR, weil er sich das Galaxy Note 10.1 holte.
Hält man das Xoro Pad 9719QR in den Händen, meint man ein iPad vor sich zu haben: Metallgehäuse, saubere Verarbeitung, Retina-Display, 2GB RAM, 16GB interner Speicher; allerdings mit mehr Anschlüssen und einem zusätzlichen Micro SD-Karten-Slot. Das Tablet läuft zwar noch mit Android 4.2.2, macht aber trotzdem Spaß. Da es hierfür nun allerdings kein Android-Update mehr gibt, was ich allgemein für äußerst fahrlässig und schwachsinnig halte (in Bezug auf alle Android-Geräte im Vergleich zu iOS), muss ich mir also selbst helfen, weshalb das Tablet jetzt erstmal gerootet wurde. Was ich im nächsten Schritt drauf schaufle (Cynogen oder etwas anderes) wird sich zeigen.
Der Root-Vorgang an sich war jedenfalls problemlos und schnel erledigt. Leider funktionierte GeoHot's "Towelroot" nicht, weshalb ich mir mit ein paar Treibern, einem Windows-Tool und diesen Anleitungen weiterhalf:

http://www.androidpit.de/forum/602265/tutorial-xoro-pad-9719qr-root-custom-rom
http://www.xoro.tv/index.php?page=Thread&postID=74133

Benötigte Software:

1. Androidtreiber
2. Rockchiptreiber
3. Xoro Tool v1.0.3beta
4. Custom ROM

Ich schloss das Tablet also wie beschrieben an und installierte die Treiber aus Punkt 1 und 2. Danach startete ich das XORO Tablet Tool, welches mein Tablet jedoch partout nicht finden wollte.

***LÖSUNG***

1. Zunächst benötigt man ein Verzeichnis namens .android unter C:\Windows\Benutzer\Benutzername. Existiert dieses schon, löscht man es oder benennt es einfach um. Das neue lässt sich über den Explorer nicht so leicht anlegen, weshalb man über die CMD gehen muss:

cd C:\
md .android


Das war's schon. Anschließend wechselt man ins eben erstellte Verzeichnis und legt sich eine adb_usb.ini an, in die man abschließend folgenden Wert einträgt: 0x2207

Danach klickt man im Tool auf "Erneut einlesen" und schon wird das Tablet gefunden und der Rootvorgang kann durchgeführt werden. Dieser ist schnell erledigt und das Tablet danach neu gestartet.
Mit den Apps "SuperSU" und dem "ES Datei Explorer" (Root-Modus = Ein) ließ sich der erfolgreiche Vorgang abschließend auch erfolgreich prüfen und bestätigen.

Als nächstes stellt sich die Frage nach einem Custom ROM. Cynogen Mod mit dem aktuellsten Android Unterbau würde mir gut gefallen. Diesbezüglich muss ich aber mal recherchieren, ob die Rockchips inzwischen unterstützt werden.

Page 3 of 14, totaling 66 entries